Video - Truyền thông Profibus PLC - Biến Tần không thể dễ hơn

Thảo luận trong 'Video độc quyền phát hành bởi vọc sỹ admin' bắt đầu bởi admin, 19/10/14.

  1. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Hôm nay em có kết nối và mở starter lên tìm kiếm thì nó ra như vậy lv.
    Hệ thống của em gồm : Biến tần(mm420) kết nối profibus với PLC S7-300 và em dùng cáp MPI để download chương trình xuống PLC. Vậy biến tần có nhận được thông số em cài trên starter ko ạ?(Em ko dùng cáp gì để download trực tiếp xuống biến tần).
    Kết quả là khi em Run PLC thì Biến tần ko có những thông số mà em đã cài, còn nếu em cài đặt bằng tay trên biến tần(điều kiện là P0700=6, p1000=6) thì khi Run PLc nó lại nhận giá trị setpoint nhưng động cơ vẫn ko chạy.
    em mong Admin và anh Tú chỉ giúp em với ạ.
    em hi vọng được xem video hướng dẫn sắp tới ạ!
     
  2. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    Video có rồi.đợi ad up lên thôi.em phải chọn chuẩn kết nối là profibus.thì mới kết nối được plc và biến tần cùng lúc
     
    dangbun thích bài này.
  3. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    em đã chọn PG/PC là profibus rồi mà anh tú. Em còn chổ nào sai xót hả anh?
     
  4. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    Biến tần của e phải down bằng stater mà.em đã down file cấu hình đó xuống đâu mà.em dùng cáp kết nối của em viéi pc.nối vào biến tần,chạy stater rồi down nó xuống biến tần
     
    dangbun thích bài này.
  5. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Down bằng cáp riêng hay sao anh tú?. Hôm nay em down xuống PLC mà cứ tưởng có kết nối cáp profibus nên nó cũng down xuống biến tần. Anh tư vấn giúp em với ạ!
     
  6. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    Cái connect dp của e có xếp chồng được không.Nếu xếp chồng được thì cáp cắm vào cổng dp của cpu nối tiếp sang biến tần.chọn chuẩn profibus mà online cả 2.Nếu Ko thì cắm cáp riêng vào biến tần mà don.cáp của e hỗ trợ profibus là được
     
    dangbun thích bài này.
  7. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    A đang online băng điện thoại với lại Ko ở phòng.không thì a chụp ngay cho cái ảnh a đang nối ở phòng cho e xem
     
    dangbun thích bài này.
  8. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    1 đầu cáp profibus trên plc có xếp chồng, còn trên biến tần thì ko. Vậy thì em lấy cái cáp MPI cắm vào chổ xếp chồng trên plc rồi chọn chuẩn Profibus để nạp chương trình trên PLc lẫn biến tần và sau đó là online cả 2 . Em làm vậy có đúng ko anh Tú ạ!?
     
  9. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Dạ. Mà anh ơi mai mấy giờ anh rảnh? có gì anh teamview chỉ em với, để anh coi kết nối thực tế của nó và chỉ lổi cho em với. Lúc đó em kết nối hệ thống luôn ak. Chứ giờ em về phòng ko kết nối dc.
     
  10. admin

    admin Chia sẻ để cùng phát triển Thành viên BQT

    Tham gia ngày:
    15/1/13
    Bài viết:
    3,168
    Đã được thích:
    2,327
    Điểm thành tích:
    113
    Giới tính:
    Nam
    Nghề nghiệp:
    Automation Engineer
    Nơi ở:
    Sài Gòn
    Web:
    Đang up lên, mạng hơi chậm.
     
    dangbun thích bài này.
  11. admin

    admin Chia sẻ để cùng phát triển Thành viên BQT

    Tham gia ngày:
    15/1/13
    Bài viết:
    3,168
    Đã được thích:
    2,327
    Điểm thành tích:
    113
    Giới tính:
    Nam
    Nghề nghiệp:
    Automation Engineer
    Nơi ở:
    Sài Gòn
    Web:
    Đã lên video nha. Xem trang đầu tiên
     
    dangbun thích bài này.
  12. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    cho em hỏi cái hàm FC52 trong chương trình viết như thế nào ạ!
     
  13. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    cái đấy tương đương với hàm Scale AO, xem lại video cũ cái chỗ Speed setpoint ấy,
     
    dangbun thích bài này.
  14. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Giúp em với ạ!
    Khi em chưa download được thông số xuống biến tần bằng phần mềm starter (vì một số trục trặc) nên em đã cài đặt thông số bằng BOP như sau: (để truyền thông profibus giữa plc và biến tần mm420)
    P0003=3
    P0304=380
    P0305=0.41
    P0307=0.15
    P0308=0.79
    P0310=50
    P0311=1330
    P0700=6
    P1000=6
    P3900=3
    P0010=0

    Và bắt đầu RUN plc và cho I0.0 lên 1( để chạy động cơ ) thì trên màn hình biến tần nó báo lổi F0070 (lỗi giá trị điểm đặt CB)
    Vậy cách khắc phục lỗi này như thế nào ạ! Em cài đặt thông số như vậy đã đúng hay chưa ạ!
    Em cảm ơn ạ!
     
  15. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Untitled.
    Lúc modify giá trị tóc độ trong chương trình thì màn hình biến tần nó hiện tốc độ còn động cơ không chạy ạ!
    Đèn báo truyền trông trên biến tần nó màu xanh mà vẫn không truyền thông được ạ!
    Mong admin và anh @nguyenanhtu1989 xem giúp em ạ!
    Em cảm ơn nhiều ạ!
     
  16. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    em kiểm tra đặt p849 đặt =1 xem sao
     
    dangbun thích bài này.
  17. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    @admin và anh @nguyenanhtu1989 giúp em với ạ!
    Nhờ sự giúp đỡ tận tình của ADMIN và anh TÚ thì em cũng đã làm tạm ổn truyền thông profibus giữa PLC và biến tần MM420 rồi ạ!
    Bây giờ em muốn điều khiển PID từ PLC xuống Biến tần qua profibus để điều khiển động cơ (trên động cơ có gắn Encoder). Và lấy tín hiệu hồi tiếp từ Encoder về Biến tần ,Từ biến tần gửi lên PLC, cuối cùng PLC xuất lệnh điều khiển PID xuống.
    Em đã làm 1 cái chương trình đươn giản để hiểu gồm có các hàm điều khiển PID như FB41,DB41,OB35.
    Vậy bây giờ em muốn lấy tín hiệu từ Encoder lên biến tần sau đó truyền qua PLC ,đồng thời PLC điều khiển PID để động cơ chạy ổn định thì phải làm thế nào ạ!
    Em hi vọng 2 anh sẽ làm cái Video hướng dẫn để em hiểu rõ và làm tót hươn ạ!
    Em xin chân thành cảm ơn ạ!
     
  18. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    PID của em định lấy tín hiệu phản hồi tốc độ về điều khiển tốc độ động cơ anh thấy không hợp lý lắm,em nên xem lại yêu cầu của em :)
     
    dangbun thích bài này.
  19. dangbun

    dangbun New Member

    Tham gia ngày:
    29/3/16
    Bài viết:
    46
    Đã được thích:
    3
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Dạ em cũng tính làm theo hướng PID đó nhưng chưa rõ lắm. Mong anh Tú chỉ ra hướng giúp em ạ! Chắc em hiểu sai hướng làm rồi ạ!
    Em cảm ơn ạ!
     
  20. nguyenanhtu1989

    nguyenanhtu1989 Moderator

    Tham gia ngày:
    18/11/13
    Bài viết:
    226
    Đã được thích:
    199
    Điểm thành tích:
    43
    Giới tính:
    Nam
    Nơi ở:
    Tuyên Quang
    Mục đích của em là sử dụng PID của PLC ah.em làm bài toán ổn định và điều khiển lưu lượng hay áp suất theo tốc độ bơm chẳng hạn
     
    Chỉnh sửa cuối: 11/4/16
    dangbun thích bài này.

Chia sẻ trang này